Vous êtes ici

demande d'aide

Vous avez 30 secondes ?
S'abonner au flux d'actualités
12 contributions / 0 nouveau(x)
Dernière contribution
demande d'aide
Bonjour Tout le monde,
 
j'ai un site que je dois le faire fonctionner .
je suis debutante avec drupal et je demande de l'aide .
je ne comprend plus rien j'ai téléchargé le site en locale 
j'ai exporter la base

j'ai transféré la racine avec FTP

j'ai crée la base
j'ai modifié le settings.php comme suit :
$databases = array (
'default' =>
array (
'default' =>
array (
'database' => 'rbzimmocvo1',
'username' => 'root',
'password' => '123456',
'host' => 'localhost',
'port' => '',
'driver' => 'mysql',
'prefix' => 'rbz',
),
),
);

-------------> quand je lance mon navigateur il m'affiche l'erreur suivante:
Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator at admin@example.com to inform them of the time this error occurred, and the actions you performed just before this error.

More information about this error may be available in the server error log.

Apache/2.4.9 (Win64) PHP/5.5.12 Server at localhost Port 80

a titre d'information je n'ai pas drupal installer sous mon serveur WAMP
Si vous pouvez m'aidé. merci d'avance

This post is useful!
This post is useless!
Re: demande d'aide
Bonjour !
Qu'est-ce que vous voulez dire par "j'ai pas Drupal installé sous mon serveur WAMP" ?
Utilisez-vous Acquia Dev Desktop ?
Avez-vous essayez update.php (<monsite.com>/update.php)
Est-ce un Drupal 7 ou Drupal 8 ?
This post is useful!
This post is useless!
Re: demande d'aide
Bonjour Dominique 
 
- c'est a dire j'ai téléchargé le dossier global du site (la racine), j'ai exporté la base via phpmyadmin.
j'ai mis le dossier DEV qui contien le site normalement sous www et j'ai importé la base .
quand je tape localhost/dev   sous mon navigateur le message d'erreur que j'ai sité s'affiche .
merci pour votre aide !
This post is useful!
This post is useless!
Re: demande d'aide
Vous n'avez pas répondu à toutes mes questions, alors je vais supposé que vous utilisez WAMP.
Videz les fichiers : C:\wamp\logs\apache_error.log et C:\wamp\logs\php_error.log
Retournez sur votre site.
Lorsque l'erreur s'affiche dans votre navigateur, regardez les dernières lignes ajoutées dans ces deux fichiers.
This post is useful!
This post is useless!
Re: demande d'aide
Excuse moi Dominique, comment faire pour effecer ces deux fichier ?
This post is useful!
This post is useless!
Re: demande d'aide
Ne les effacez pas, videz les.
Clic-droit / Propriétés => décochez lecture seule si c'est le cas
Ensuite, clic-droit, ouvrir avec Notepad++ (je vous conseil vivement cet excellent éditeur de texte !)
Sélectionnez tout => Supprimez
Puis enregistrez le fichier vide
This post is useful!
This post is useless!
Re: demande d'aide
Bonjour Dominique et merci pour votre aide,
voila j'ai refais tt : j'ai crée de nouveau la BD , j'ai mis les infos necessaire dans setting.php.
la page web m'affiche le message suivant :
Error
The website encountered an unexpected error. Please try again later.
Error message
PDOException: SQLSTATE[42S02]: Base table or view not found: 1146 Table 'rbzimmocvo1.semaphore' doesn't exist: SELECT expire, value FROM {semaphore} WHERE name = :name; Array ( [:name] => variable_init ) in lock_may_be_available() (line 167 ofC:\wamp\www\dev\includes\lock.inc).
Uncaught exception thrown in shutdown function.

PDOException: SQLSTATE[42S02]: Base table or view not found: 1146 Table &#039;rbzimmocvo1.semaphore&#039; doesn&#039;t exist: DELETE FROM {semaphore} WHERE (value = :db_condition_placeholder_0) ; Array ( [:db_condition_placeholder_0] =&gt; 79445260356c6fd16802dd4.05468715 ) in lock_release_all() (line 269 of C:\wamp\www\dev\includes\lock.inc).
 

 
This post is useful!
This post is useless!
Re: demande d'aide
Bonjour,
Vérifiez bien que les données du settings.php correspondent à la base de donnée importée. En particulier, que vous pointez bien vers la bonne base de donnée, que le prefixe des tables est le bon (il y a un préfixe dans la conf de votre premier message, mais pas dans le message d'erreur de votre dernier message).
Vérifiez ensuite que toutes les tables de votre BDD on bien été transférées en locale, le message d'erreur indique que la table semaphore n'a pas été trouvée dans votre base rbzimmocvo1.
This post is useful!
This post is useless!
Re: demande d'aide
Encore une fois merciiiiiiiiiiiiiiiiiiiiii Dominique !
Le site tourne en local mais il est treeeeeeees lourd  déja je n'arrive pas a navigué entre les pages .
je ne sais pas pour quel raison !
 
This post is useful!
This post is useless!
Re: demande d'aide
Bonsoir,
C'est la raison pour laquelle je ne conseille pas WAMP pour Drupal (et pour les CMS de manière générale).
Je conseille fortement Acquia Dev Desktop :
This post is useful!
This post is useless!
Re: demande d'aide
Bonjour,
le problème c'est que ce site étais hebergé sur internet et il a rencontré les memes problèmes: impossibles d'ajouter du contenu et le site rame troooooooooop !
d'avance merci 
This post is useful!
This post is useless!
Re: demande d'aide
Bonjour Dominique et merci pour votre aide;
je veux savoir comment je peux rendre mon site plus léger .
psq meme quand il etais sur internet il avais le meme problème de lenteurs.
This post is useful!
This post is useless!
Connectez-vous ou inscrivez-vous pour publier un commentaire